tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <>
Subject Re: JMX Remote connection
Date Wed, 06 Oct 2004 17:08:24 GMT
Remy Maucherat wrote:
> Dominik Drzewiecki wrote:
>> Why don't we dump the JkMX and just settle for the facilities provided 
>> by Java 5 configurable via standard system properties: 
>> alone for local JVM monioring
>> or
>> for remote machine monitoring.

Because they don't work with JDK1.4, and any people (including me) can't 
switch to Java5 since it breaks too much :-)

The option you mention are in fact the same thing with the webapp I'm 
suggesting - they have the effect of loading the standard connector. The difference is that jx.m.r is 
using the standard API and will work with any JMX implementation, while
"com.sun" is specific to sun's implementation of jmx.

>> I checked both myself with jconsole shipped with Java 5. It works like 
>> a charm (apart from increased CPU Load on the machine the jconsole runs).
>> MC4J 1.2 B5 has no problems with attaching to remote JVM either, 
>> hovewer it has some issues with mbeans provided by JVM, MC4J folks are 
>> aware of.
>> The bottomline is: consider dumping o.a.jk.c.JkMX (I know, I know 
>> there is number of users wishing to run tomcat on JVM <1.5)
> Your post motivated me for trying jconsole, and I have to say it's 
> really good.

Yes, jconsole is the reason I wrote the app too. Plus the fact that 
mx4j2.0 no longer works with jkmx ( they dumped the connector beans from
distribution since they now support the standard jx.m.r )

> As others have said, the problem with JkJMX is that it's annoying to 
> keep it up to date. And when we had it up to date, the JMX client was 
> then rarely up to date. So I'll let you guys decide what do do, but it's 
> sort of obvious the need for that kind of stuff is a lot smaller than 
> what it used to be for Tomcat 5.5.
> Note: the main reason why I removed is because is has a 
> very confusing name (again referring to mod_jk2); if it's really needed, 
> then it should be renamed, or an alternate name should be allowed.

No, removing - and removing JkMX - is a good thing.

I'll check in the webapp code, it's easier to talk about code - if 
people don't like it, feel free to -1 :-)


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message