tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jess Holle <je...@ptc.com>
Subject Re: 5.0.29 JSP compilation fails when using JDK 1.5.0
Date Mon, 18 Oct 2004 20:46:45 GMT
Okay, I now (belatedly) understand the problem.

The issue is that by default Jaspper is setting the target release to 
1.3 but leaving the source release unspecified -- resulting in the JDK 
1.5 javac default source release, 1.5 -- and javac won't allow this mixture.

I am attaching a set of patches that (1) defaults the source release to 
1.3 as well and (2) allows this to be controlled in a completely 
independent and analogous manner to target release.

I would appreciate seeing this in 5.0.30 :-)

--
Jess Holle


Mime
View raw message