tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jess Holle <je...@ptc.com>
Subject Re: 5.0.29 JSP compilation fails when using JDK 1.5.0
Date Thu, 14 Oct 2004 17:29:56 GMT
Any chance of a 5.0.30 with this resolved in the near future?

[I take it you're back from vacation, Yoav, as I see CVS commit notices 
with your name on them.]

--
Jess Holle

Shapira, Yoav wrote:

>Hi,
>Thanks for spotting and reporting this issue.  While Tomcat 5.0.x
>doesn't officially support J2SE 5.0, we don't want to make things worse
>with new releases ;)  So my apologize for this issue.
>
>I'm really busy today and tomorrow at work, and then I'm traveling this
>weekend [it's a long holiday weekend in the US].  If someone could at
>least post a .diff patch to fix this, I'd be grateful and I'll try to
>commit it quickly.  If we wait for me, this issue might have to wait a
>few days ;)
>
>Thanks,
>
>Yoav Shapira
>Millennium Research Informatics
>  
>
>>-----Original Message-----
>>From: Jess Holle [mailto:jessh@ptc.com]
>>Sent: Wednesday, October 06, 2004 3:55 PM
>>To: Tomcat Developers List
>>Subject: 5.0.29 JSP compilation fails when using JDK 1.5.0
>>
>>Tomcat 5.0.28 compiled JSP pages when run using JDK 1.5.0 just fine
>>(out-of-the-box). Also, 5.0.28 seems to work fine under JDK 1.5.0 in
>>general.
>>
>>Tomcat 5.0.29 can no longer compile JSP pages when running under JDK
>>1.5.0! Given that 1.5.0 has been released and 5.0.28 works fine, I
>>believe this is a serious regression in 5.0.29 that should by itself
>>prevent it from getting a "stable" rating -- though I'd love to quickly
>>see a 5.0.30 including a fix for this :-)  [Tomcat 5.0.29 does seem to
>>work alright under 1.5.0 if you pre-compile all JSP pages via an Ant
>>project...]
>>
>>Note that the startup environment, JSP pages, etc, are identical in
>>    
>>
>both
>  
>
>>cases.  In both cases I use "catalina.50.bat start".  Also note that
>>    
>>
>the
>  
>
>>JSP pages use no 1.5 features whatsoever -- I'm just trying to run with
>>JDK 1.5.0.  Also, both results hold both for "development" Jasper
>>settings (fork=false, development=true, reloading=true) and "production
>>Jasper settings (fork=true, development=false, reloading=false).
>>
>>The symptom when this fails is the following console message:
>>
>>   javac: target release 1.3 conflicts with default source release 1.5
>>
>>I am *guessing* this may have something to do with the following change
>>log entry:
>>
>>   30984 <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=30984>:
>>   Added compilerTargetVM option to Jasper. (yoavs)
>>
>>--
>>Jess Holle
>>    
>>
>
>
>
>
>This e-mail, including any attachments, is a confidential business communication, and
may contain information that is confidential, proprietary and/or privileged.  This e-mail
is intended only for the individual(s) to whom it is addressed, and may not be saved, copied,
printed, disclosed or used by anyone else.  If you are not the(an) intended recipient, please
immediately delete this e-mail from your computer system and notify the sender.  Thank you.
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
>
>
>  
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message