tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 31465] - JSP encoding is wrong
Date Mon, 04 Oct 2004 19:14:36 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=31465>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=31465

JSP encoding is wrong

kin-man.chung@sun.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|WONTFIX                     |



------- Additional Comments From kin-man.chung@sun.com  2004-10-04 19:14 -------
On second thought, what I said wasn't entirely correct.  :(

Jasper is still correct to output the bytes 0xc2a9 because of the difference in
encoding.  However, druing javac compilation, these bytes should be translated
back to the original 0xa9, and everything should be OK.  The problem seems to be
in the JDT compiler, or its setup codes.

As a work around, use ant compilation to use JDK 1.4 javac.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message