tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cmanola...@yahoo.com>
Subject Re: [5.5] Packaging
Date Wed, 25 Aug 2004 16:27:04 GMT
Shapira, Yoav wrote:
> Hi,
> 
> 
>>>Please make sure "target=1.3" is present in all javac tasks :-)
>>
>>Shouldn't we support only JRE 1.4 and 5.0 instead ? I would be able to
> 
> 
> I'm also not big on JDK 1.3 as the default target.  I'm +0 on adding a
> "javaTarget" build.properties attribute that users can set to "1.3" but
> whose default value is 1.4, 1.5, or none, but not 1.3.  I haven't seen a
> question on tomcat-user with someone running JDK 1.3 for a long time
> now.

Maybe that's because they don't have "endorsed" problems and things just 
work and are stable :-)

"Write once, run anywhere" - why would you choose a target that will not 
run for a (significant) number of people, and try to force them to 
choose between upgrading tomcat and upgrading other software ?

What do we gain ? Few features that are available anyway - with many 
choices of better implementations.

Sun has the bad habit of breaking compatibility and the "run anywhere" 
promise on every release. 5.0 is particularly bad. I consider "run 
anywhere" one of the essential things in java - including the ability to
run with other vendor or open source VMs.


Costin


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message