tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cmanola...@yahoo.com>
Subject Re: [5.5] Packaging
Date Wed, 25 Aug 2004 16:15:55 GMT
Remy Maucherat wrote:
>>
>> Please make sure "target=1.3" is present in all javac tasks :-)
> 
> 
> Shouldn't we support only JRE 1.4 and 5.0 instead ? I would be able to 
> replace jakarta-regexp use with Java regexp. Obviously people who don't 
> want to upgrade (ex: I saw a really funny thread on tomcat-user about a 
> guy who wants JMX runtime stats on 4.1.x, like the ones that were in 
> 5.0.x) aren't going to upgrade to this new branch, because of API breakage.

I'm using 1.3 most of the time, there is a _lot_ of software out there 
that doesn't work in jdk1.4 and won't work in jdk1.5 either. Not to 
mention companies having policies and supporting only one VM ( so they
don't have to deal with all the incompatibilities between versions ).

I'm personally -1 on droping support for 1.3 ( well, I would be +1 on 
supporting J2ME or 1.1 as a baseline :-).

Even compiling software with jdk1.5 or loading it in an IDE is problematic.

I think we should value stability more than featurism - and value 
flexibility and modularity more than bloat. There are people who have
problems with the Sun/Microsoft policy of bundling features in order to
reduce competition  ( logging, mx4j/jbossmx, jakarta-regexp, parser, etc 
). Especially when those features are hard to replace with better 
implementations ( even if they implement an API and have some convoluted 
"endorsed" setting to replace ).


Costin


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message