tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cmanola...@yahoo.com>
Subject Re: [5.5] Packaging
Date Tue, 24 Aug 2004 20:16:23 GMT
Remy Maucherat wrote:

> No, you misunderstood.
> 
> - jakarta-tomcat-5.5.0.zip - for JRE 5.0, no Admin
> - jakarta-tomcat-5.5.0.tar.gz -  for JRE 5.0, no Admin
> - jakarta-tomcat-5.5.0.exe - for Windows, everything


> - jakarta-tomcat-5.5.0-compat.zip - for JRE 1.4 (a few additional JARs, 
> not the whole thing)
> - jakarta-tomcat-5.5.0-compat.tar.gz -  for JRE 1.4, no Admin

You mean mx4j ? I'm not sure about having the main target be a JRE beta,
but I understand your point, it's cleaner this way. The alternative 
would be to have a 1.4 distro, with mx4j jars included, and detect at
runtime if it's 1.5 and skip them from the loader.

I suspect people will keep using 1.4 and 1.5 for a while, as usual there 
are incompatibilities - so it's better to be able to use the same tomcat 
with both.

Please make sure "target=1.3" is present in all javac tasks :-)


> - jakarta-tomcat-5.5.0-admin.zip - admin WAR + the XML file
> - jakarta-tomcat-5.5.0-admin.tar.gz - admin WAR + the XML file

Good.

Costin



> 
>> Maybe we should have admin separately, i.e.
>> jakarta-tomcat-5.5.0-admin.war (complete with META-INF/context.xml),
>> that users can just drop into their webapps directory?  I'd rather have
>> that than 6 more binary distributions.
>>  
>>
> IMO, the admin webapp is better located in the special folder we're 
> using right now. It helps with catalina_base.
> 
>> What about dropping .tar.gz distros?  I realize its files are smaller
>> than zip, but every platform has zip support and I doubt many of our
>> users (who are mostly developers for companies or open-source
>> afficionadoes) are on dialup connections.  Alternatively (this is what
>> JonAS has done for example) we could just have .tgz files which the
>> Windows Winzip can handle.  This saves the release manager work and
>> reduces user confusion slightly, as they are faced with less download
>> choices.  I see the latter (user confusion) increasing when we have
>> JRE1.4 and JRE5.0 distros.
>>
> This is a bad idea.
> - Windaube XP only supports .zip
> - tgz allows setting Unix execute flag
> 
> Rémy


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message