tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cmanola...@yahoo.com>
Subject Re: both jdk1.5 and jdk1.4 needed to build tomcat????
Date Fri, 13 Aug 2004 15:04:29 GMT
What I did is add

    target="1.3" source="1.3"

on each <javac > target in build.xml files failing under 1.5.

Also in Eclipse java/compiler/compliance - 1.3, and same in idea.

This lets me compile with 1.5 or eclipse ( I have it set to generate 
classes in the same dir ant would compile - so ant is only doing the 
packing ). I use JDK1.3 mostly for OptimizeIt, I have a very old version
that doesn't support 1.4+.

Costin

Shapira, Yoav wrote:
> Hi,
> Note also that CVS HEAD is not guaranteed to be stable until we make a
> release.  If you want a stable reproduction of current code, do your
> checkouts with the TOMCAT_5_0 branch.
> 
> Yoav Shapira
> Millennium Research Informatics
> 
> 
> 
>>-----Original Message-----
>>From: Hiller, Dean D (Dean) [mailto:dhiller@avaya.com]
>>Sent: Thursday, August 12, 2004 5:52 PM
>>To: Tomcat Developers List
>>Subject: RE: both jdk1.5 and jdk1.4 needed to build tomcat????
>>
>>Thanks, I will do that.
>>dean
>>
>>-----Original Message-----
>>From: Filip Hanik - Dev [mailto:devlists@hanik.com]
>>Sent: Thursday, August 12, 2004 3:49 PM
>>To: Tomcat Developers List
>>Subject: Re: both jdk1.5 and jdk1.4 needed to build tomcat????
>>
>>It works for me with those steps using JDK 1.4, no problem
>>
>>if you need to try again, I suggest to clean your machine, and start
>>over (this includes all the downloads in /usr/share/java)
>>
>>Filip
>>
>>----- Original Message -----
>>From: "Hiller, Dean D (Dean)" <dhiller@avaya.com>
>>To: "Tomcat Developers List" <tomcat-dev@jakarta.apache.org>
>>Sent: Thursday, August 12, 2004 4:38 PM
>>Subject: both jdk1.5 and jdk1.4 needed to build tomcat????
>>
>>
>>I for some reason needed 1.4jdk and 1.5jdk to build tomcat.  My steps
>>are below.  Any help would be appreciated as to how I can correct
>>this....
>>
>>Using jdk1.5 and Filip's great list of steps(thanks Filip, the list
> 
> made
> 
>>life easier, and I am almost there)
>>
>>I go through the list to build tomcat
>>
>>1. cvs co jakarta-tomcat-5
>>works great
>>2. cd jakarta-tomcat-5
>>obviously works
>>3. ant update
>>works great
>>4. ant download
>>breaks, and looks like 1.5 problems, so I switch to 1.4 and it
>>works!!!.  Basically the tomcat-deps module is not compiling in 1.5 as
>>it conflicts with many different things.
>>
>>5. ant dist
>>sticking with 1.4 doesn't work, and going to 1.5 doesn't work.
>>
>>So now, I am basically stuck again on Jakarta-tomcat-5/build/classes
> 
> not
> 
>>compiling at all.  I am not sure where to go.  I am trying to think
> 
> what
> 
>>are the possibilities of what is wrong.
>>1. I need to do some configuration which I haven't done.
>>2. Builds currently don't work if starting from scratch as something
> 
> was
> 
>>modified on accident?
>>3. they do work if you already had everything downloaded?
>>
>>I followed the steps above twice.  I don't suppose having to switch
>>between 1.4 and 1.5 makes my situation easier to debug, as that could
> 
> be
> 
>>part of my problem too.  Don't suppose someone just wants to send me a
>>zipped up version of their view that builds??  I would like to fix this
>>and will continue to look at the problem, but I am not really sure
> 
> where
> 
>>to start so it may take me some time as I jump into all this.
>>Thanks,
>>dean
>>
>>
>>
>>-----Original Message-----
>>From: Mark Thomas [mailto:markt@apache.org]
>>Sent: Thursday, August 12, 2004 2:16 PM
>>To: 'Tomcat Developers List'
>>Subject: RE: tomcat build broken with strange javac error(never seen
>>this one before)
>>
>>1. Ignore the "stop sending me mail" message. Someone has managed to
> 
> get
> 
>>themselves subscribed to the list and is obviously incapable of
>>following the
>>simple instructions included in every mail to unsubscribe. One of the
>>list
>>owners (of which I am one) will sort this out.
>>
>>2. & 3. The right place to posts depends on the question and will
> 
> always
> 
>>be a
>>judgement call and different people will make different judgements. I
>>wouldn't
>>worry about it too much - personally I thought this one was on the
>>border line.
>>
>>Mark
>>
>>
>>>-----Original Message-----
>>>From: Hiller, Dean D (Dean) [mailto:dhiller@avaya.com]
>>>Sent: Thursday, August 12, 2004 8:29 PM
>>>To: Tomcat Developers List
>>>Subject: RE: tomcat build broken with strange javac
>>>error(never seen this one before)
>>>
>>>Huh, 3 questions about this mail list then.....
>>>
>>>1. confused by "stop sending me mail" when this is my first
>>>mail to this
>>>list
>>>2. Huh, I thought building would be a developer issue????
>>>3. Where should I post future questions on the source code I
>>>am looking
>>>at in tomcat???  The users list states it is for configuration
> 
> issues,
> 
>>>etc.
>>>
>>>ps. Thanks shapira for the jdk1.5 note.  That makes sense, duh.
>>>Thanks,
>>>dean
>>>
>>>-----Original Message-----
>>>From: Joshua Paul [mailto:joshua@arimiami.com]
>>>Sent: Thursday, August 12, 2004 1:21 PM
>>>To: Tomcat Developers List
>>>Subject: Re: tomcat build broken with strange javac error(never seen
>>>this one before)
>>>
>>>Stop sending me e-mail.
>>>----- Original Message -----
>>>From: "Hiller, Dean D (Dean)" <dhiller@avaya.com>
>>>To: <tomcat-dev@jakarta.apache.org>
>>>Sent: Thursday, August 12, 2004 3:00 PM
>>>Subject: tomcat build broken with strange javac error(never seen this
>>>one
>>>before)
>>>
>>>
>>>I have never seen an error from javac like this before(and I am by no
>>>means new to java).  I have even read the JLS and am not sure what in
>>>the world this is.  Can anyone point me somewhere on how to
>>>resolve this
>>>issue?  Or possibly point me to a build.xml for tomcat5 that
>>>works?  The
>>>one on the website does not work as I get the below.  I am using
>>>1.4.2_05.  Does the build.xml file work for anyone else?  If so, what
>>>version of java are you using?
>>>
>>>
>>>
>>>
>>>
>>>build-catalina-core:
>>>
>>>    [javac] Compiling 302 source files to
>>>C:\ROOT\views\jakartaviews\tomcatTry\jakarta-tomcat-5\build\classes
>>>
>>>    [javac]
>>>C:\ROOT\views\jakartaviews\tomcatTry\jakarta-tomcat-catalina\c
>>>atalina\sr
>>>c\share\org\apache\catalina\Container.java:23: cannot access
>>>javax.servlet.ServletException
>>>
>>>    [javac] bad class file:
>>>C:\usr\share\java\servlet-api-2.4\lib\servlet-api.jar(javax/se
>>>rvlet/Serv
>>>letException.class)
>>>
>>>    [javac] class file has wrong version 49.0, should be 48.0
>>>
>>>    [javac] Please remove or make sure it appears in the correct
>>>subdirectory of the classpath.
>>>
>>>    [javac] import javax.servlet.ServletException;
>>>
>>>    [javac]                      ^
>>>
>>>    [javac] 1 error
>>>
>>>
>>>
>>>Also, I really want to know more about this error and how it is
>>>possible.  Does anyone know what this means?  Ps.  Am I on the wrong
>>>list?  Is this really a problem with the servlet api jar?, but which
>>>project is that and who do I talk to???
>>>
>>>thanks,
>>>
>>>dean
>>>
>>>
>>>
>>>
>>>---------------------------------------------------------------------
>>>To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
>>>For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
>>>
>>>
>>>---------------------------------------------------------------------
>>>To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
>>>For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
>>>
>>>
>>
>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
>>For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
>>For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
>>For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
>>For additional commands, e-mail: tomcat-dev-help@jakarta.apache.or
> 
> g


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message