tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: [5.5] Packaging
Date Wed, 25 Aug 2004 16:34:28 GMT

Hola,

>"Write once, run anywhere" - why would you choose a target that will
not
>run for a (significant) number of people, and try to force them to
>choose between upgrading tomcat and upgrading other software ?

I don't think the number is significant.  It's very subjective, and I
have no empirical data, just opinion from the tomcat-user list.  If
someone could show, for example, that more than a tenth of Tomcat users
run with JDK 1.3 in production, I'd be convinced me JDK 1.3 is still
significant.

I completely agree WORA is essential, possibly the biggest advantage of
the Java language/platform.  But then why aren't we coding/building to
JDK 1.1 or J2ME?  It's a question of tradeoffs.  Maybe we should have a
vote on whether Tomcat 5.5 should require JDK 1.5?



This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged.  This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else.  If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message