tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiller, Dean D (Dean)" <dhil...@avaya.com>
Subject solved thanks, all, moron me
Date Thu, 12 Aug 2004 22:11:50 GMT
I should have read this e-mail better I realized.  Sorry for being a
timesuck.  Should have just use 1.4 from the start.
dean

-----Original Message-----
From: Shapira, Yoav [mailto:Yoav.Shapira@mpi.com] 
Sent: Thursday, August 12, 2004 1:11 PM
To: Tomcat Developers List
Subject: RE: tomcat build broken with strange javac error(never seen
this one before)

Hi,
The build file works for me.

Your servlet-api jar was built with JDK 1.5, so you must build the rest
of Tomcat with JDK 1.5.  Alternatively, build servlet-api.jar with JDK
1.4 and build the rest of Tomcat with JDK 1.4 as well.  You get the
general point ;)


Yoav Shapira
Millennium Research Informatics


>-----Original Message-----
>From: Hiller, Dean D (Dean) [mailto:dhiller@avaya.com]
>Sent: Thursday, August 12, 2004 3:00 PM
>To: tomcat-dev@jakarta.apache.org
>Subject: tomcat build broken with strange javac error(never seen this
one
>before)
>
>I have never seen an error from javac like this before(and I am by no
>means new to java).  I have even read the JLS and am not sure what in
>the world this is.  Can anyone point me somewhere on how to resolve
this
>issue?  Or possibly point me to a build.xml for tomcat5 that works?
The
>one on the website does not work as I get the below.  I am using
>1.4.2_05.  Does the build.xml file work for anyone else?  If so, what
>version of java are you using?
>
>
>
>
>
>build-catalina-core:
>
>    [javac] Compiling 302 source files to
>C:\ROOT\views\jakartaviews\tomcatTry\jakarta-tomcat-5\build\classes
>
>    [javac]
>C:\ROOT\views\jakartaviews\tomcatTry\jakarta-tomcat-catalina\catalina\s
r
>c\share\org\apache\catalina\Container.java:23: cannot access
>javax.servlet.ServletException
>
>    [javac] bad class file:
>C:\usr\share\java\servlet-api-2.4\lib\servlet-api.jar(javax/servlet/Ser
v
>letException.class)
>
>    [javac] class file has wrong version 49.0, should be 48.0
>
>    [javac] Please remove or make sure it appears in the correct
>subdirectory of the classpath.
>
>    [javac] import javax.servlet.ServletException;
>
>    [javac]                      ^
>
>    [javac] 1 error
>
>
>
>Also, I really want to know more about this error and how it is
>possible.  Does anyone know what this means?  Ps.  Am I on the wrong
>list?  Is this really a problem with the servlet api jar?, but which
>project is that and who do I talk to???
>
>thanks,
>
>dean


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message