tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remy Maucherat <r...@apache.org>
Subject Re: cvs commit: jakarta-tomcat-catalina/catalina/src/share/org/apache/catalina/startup ClassLoaderFactory.java
Date Tue, 24 Aug 2004 18:51:39 GMT
Amy Roh wrote:

>>amyroh@apache.org wrote:
>>
>>    
>>
>>>amyroh      2004/08/24 10:53:52
>>>
>>> Modified:    catalina/src/share/org/apache/catalina/startup Tag:
>>>                       TOMCAT_5_0 ClassLoaderFactory.java
>>> Log:
>>> Do not load outdated xml-apis.jar & xercesImpl.jar from endorsed if JDK
>>>      
>>>
>5.0 is used.
>  
>
>>>      
>>>
>>I doubt you can use the JDK compat class from there (you're in the
>>bootstrap.jar).
>>    
>>
>
>Hmm.  Really?  I checked to see if the classLoader loads the jars.  They get
>loaded if I run on JDK 1.4 and not on JDK 5.0.
>
You got lucky: JdkCompat is actually included in bootstrap.jar. So it works.

Rémy


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message