tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfrederic.cl...@fujitsu-siemens.com>
Subject Re: Libajp -- some naming considerations.
Date Mon, 02 Aug 2004 07:13:49 GMT
Mladen Turk wrote:
> Hi,
> 
> Cause the API still in the stage of developement I'd like to make some
> renaiming, cause we'll be stuck into for a while.
> 
> 1. ajp_msg_get/peek_byte => ajp_msg_get/peek_uint8
> to be consistent with other data type, or change the ajp_msg_append from
> uint8 to byte.

+1

> 
> 2. ajp_parse_type => ajp_msg_get_type
> Makes more sense, thought.

No, ajp_msg_parse_type is better because we don't "read" the message but only 
peeek its type.

> 
> 3. ajp_parse_headers => ajp_parse_header
> think that we receive only on header message per request.
> 

+0 : I am quite bad in naming routines!
ajp_get_header would be better IMHO ;-)


> 
> Any objections?
> MT.
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message