tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 30803] New: - WebApp classloader fails to load classes from CATALINA_HOME\shared\lib
Date Mon, 23 Aug 2004 12:45:46 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=30803>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=30803

WebApp classloader fails to load classes from CATALINA_HOME\shared\lib 

           Summary: WebApp classloader fails to load classes from
                    CATALINA_HOME\shared\lib
           Product: Tomcat 5
           Version: 5.0.19
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: tal_f@lipman.co.il


In the case which my web application is located under CATALINA_HOME\webapps 
everything works fine.
But, when I take the same web application and put it outside the tomcat 
directory and add a context.xml file to CATALINA_HOME\conf\Engine\Host , this 
context points to the physical location of the webapp,what happens is that the 
context is loaded propelrly but when i try to activate my classes located 
under my webapplication/lib in a jar file which are dependant on the mysql 
jdbc jars which are located under CATALINA_HOME\shared\lib which is a valid 
place according to the class loader delegation model I get a 
ClassNotFoundException
regarding the classes located under CATALINA_HOME\shared\lib in jar files

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message