tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mladen Turk" <>
Subject Libajp -- some naming considerations.
Date Sun, 01 Aug 2004 15:21:53 GMT

Cause the API still in the stage of developement I'd like to make some
renaiming, cause we'll be stuck into for a while.

1. ajp_msg_get/peek_byte => ajp_msg_get/peek_uint8
to be consistent with other data type, or change the ajp_msg_append from
uint8 to byte.

2. ajp_parse_type => ajp_msg_get_type
Makes more sense, thought.

3. ajp_parse_headers => ajp_parse_header
think that we receive only on header message per request.

Any objections?

View raw message