tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Armstrong <a...@hexten.net>
Subject jk2 changes
Date Tue, 22 Jun 2004 20:41:34 GMT
(posted to the right list now - oops)

I'm just making sure the Lotus Domino connector works with the latest 
jk2 version. As a preamble to that I usually make sure I can get mod_jk2 
working with Apache 2 as a kind of baseline. This time I'm getting 
stuck. Is there an incompatibility between a mod_jk2 built from the 
current CVS and the 5.0.27 binary build at jakarta.apache.org?

I get encouraging looking debug from it but requests that should be 
mapped using [uri:] in workers2.properties don't seem to get outside of 
Apache (which 404s). Requests using <LocationMatch> in httpd.conf result 
in a 503 Service Temporarily Unavailable and the following in the Apache 
error log:

[error] lb_worker.service() all workers in error or disabled state
[error] mod_jk2.handler() Error connecting to tomcat 120000, status 503

My httpd.conf looks like this

LoadModule jk2_module modules/mod_jk2.so
JkSet config.file conf/workers2.properties

<LocationMatch "/*.jsp">
     JkUriSet group lb:lb
</LocationMatch>

and workers2.properties is like this

[logger]
level=DEBUG

[lb:lb]
debug=10

[channel.socket:localhost:8009]
debug=10
tomcatId=localhost:8009

[uri:/servlets-examples/*]
debug=10

[uri:/jsp-examples/*]
debug=10

Other info:
Apache/2.0.49 (Unix) mod_jk2/2.0.5-dev
Linux 2.4.22-1.2188.nptlsmp #1 SMP (Fedora Core #1)
Tomcat 5.0.27 binary from jakarta.apache.org

-- 
Andy Armstrong



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message