tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29336] New: - Unable to download PDF using MS IE 6 and SSL
Date Wed, 02 Jun 2004 08:49:35 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29336>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29336

Unable to download PDF using MS IE 6 and SSL

           Summary: Unable to download PDF using MS IE 6 and SSL
           Product: Tomcat 5
           Version: 5.0.24
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Connector:Coyote
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: i.hessing@laudert.de
                CC: i.hessing@laudert.de


In my docbase I have a folder called "pdf" containing some PDF files. In my 
webapp I use some normal anchor-tags to link to those documents so that they 
get displayed in the browser or downloaded (depending on client configuration).

With Tomcat 4.1.X everything worked well but after switching to Tomcat 5.0.24 
the request of PDFs using Microsoft Internet Explorer 6.0.2800.1106 (SP1) now 
lead to errors. Just this (unfortunately very important) browser is now unable 
to display and/or download those PDF files. With Mozilla everything still works.

I use a SSL Coyote HTTP/1.1 connector on port 443. This SSL connector seems to 
be the problem - as a non-SSL-connector still works fine with all target 
browsers. Just SSL is the problem here.

        <Connector port="443"
                   maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
                   enableLookups="false" disableUploadTimeout="true"
                   acceptCount="100" debug="0" scheme="https" secure="true" 
URIEncoding="UTF-8">
          <Factory keystoreFile="/root/.keystore"
               keystorePass="changeit"
               clientAuth="false" protocol="TLS"/>
        </Connector>

Maybe I have a hint, too: in the past I experienced some problems with dynamic 
downloads perfomed by a servlet over SLL (using MS IE 6 as the client). MS IE 6 
seems to have a bug when downloading binary data over SSL. In my download-
servlet I had to turn of caching...

    response.setHeader("Expires", "0");
    response.setHeader("Cache-Control", "must-revalidate, post-check=0, pre-
check=0");
    response.setHeader("Pragma", "public");

...to get it to work with MS IE 6.

Again, everything worked fine under Tomcat 4.1.X with its original SSL 
connector (used by default up to version 4.1.27).

Best wishes

Ingo

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message