tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 28750] New: - Forms won't save data in Authenticated Directory
Date Mon, 03 May 2004 20:09:55 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=28750>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=28750

Forms won't save data in Authenticated Directory

           Summary: Forms won't save data in Authenticated Directory
           Product: Tomcat 5
           Version: 5.0.0
          Platform: Sun
        OS/Version: Other
            Status: NEW
          Severity: Blocker
          Priority: Other
         Component: Unknown
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: tracy.pleasant@lmco.com


Currently I have an application. The main directory under the webapps/myapp all 
those files I don't need protected. I need certain pages (admin stuff) 
protected. So I put that into a /webapps/myapp/admin directory with basic 
authentication. 

My problem comes with forms. If I create a form in the webapps/myapp directory 
and hit submit, it takes user to a confirmation page of what they entered. They 
hit the back button and the form will still contain the data they just entered. 
however, if I create a form in webapps/myapp/admin directory, when user hits 
back button,none of the data is saved. I have tried this with very basic form 
as below. test2.jsp just says "TESTING". 


<form method=post action=test2.jsp>
<input type=text>
<input type=submit value=Go>
</form>

I thought that form saving data was automatic. The only difference is which 
directory I put the form in. It seems that it's not reading something properly. 
The only difference is that the admin dir I have it set so only certain users 
can enter but other than that nothing. 

I tried this in another created directory without any authentication and it 
worked (saved data after hitting back button). I am using Tomcat 5.0

PLEASE HELP!

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message