tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 28423] New: - jsp page directive doesn't work
Date Fri, 16 Apr 2004 00:25:42 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=28423>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=28423

jsp page directive doesn't work

           Summary: jsp page directive doesn't work
           Product: Tomcat 4
           Version: 4.1.29
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Unknown
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: maksymg@yahoo.com


Hi All,

I have a jsp page that prepare jnlp content for WebStart.
The jsp file start with

<%@ page contentType="application/x-java-jnlp-file" %>

When you click on the page, WebStart isn't started. The bug presents in all 
version of Tomcat 4. The last version where this code worked is Tomcat 3.2.3
Other web servers like Jetty or WebLogic has no problem with it.

For some early version of Tomcat 4 there was a bug work around:
<%
	response.setContentType("application/x-java-jnlp-file");
%>

But in the JBoss 3.2.3 that includes Tomcat the bug workaround  doesn't work 
eihter.

Best regards,
Maksym

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message