tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 28158] - Context reloadable="true" not working if autodeploy="false"
Date Fri, 02 Apr 2004 13:55:47 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=28158>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=28158

Context reloadable="true" not working if autodeploy="false"





------- Additional Comments From jaBernet@gmx.ch  2004-04-02 13:55 -------
I don't intend to waste your time. Reporting a bug costs my time too, so I only
do it if I think I found a bug, not to missuse bugzilla as a forum.

I don't know if the code you provided is correct or not, as I don't have insight
in the tomcat source. I just managed to reproduce the following behaviour in
Tomcat 5 (and 4), which is faulty IMO:

Auto-reload works fine as long as I have autodeploy="true" for the host my
context resits in. As soon is I trun autodeploy off, reloading of the context
doesn't work anymore. So the relaoding-feature of a webapp seems to be somehow
dependant of the autodeploy feature on the host.

I posted the second part with the multiple deployment only to show why I think
fixing this is important.

I'm glad to post a server.xml to show what I think is a bug. Maybe you could
confirm it then.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message