tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg.C...@pfizer.com
Subject RE: jk2 new shmem using APR
Date Tue, 09 Mar 2004 12:39:43 GMT
> > APR_HAS_SHARED_MEMORY appears bogus on Solaris 2.8 with 0.94 
> > and CVS (1.0).
> > 
> 
> First of all why? What is the reason, apr or solaris? 

Looks like it is apr.

> > How can you change the apr build as mod_jk2 builds apr when 
> > trying to make apr for apache 1.3.x?  Using Suns complier.
> > 
> 
> Seams that we only have a problem with you ;-).

That is the conclusion I have come up with too!

Basically I think we are the only people using the combination of:

new mod_jk2
apache 1.3.26
apr 0.94/1.x
Solaris 2.8
Suns workshop complier: cc: WorkShop Compilers 5.0 98/12/15 C 5.0

So our present solution is to look at moving to apache 2.x that everyone
else appears to be using.  In the meantime mod_jk2 2.0.3 works ok in our
present build.

Moving to apache 2 is a lot of work due to the compliance documentation
required, also having to build perl 5.8.3 for mod_perl and then move all our
C/Perl modules over.

> Do you have any idea how to fix the apr's shmem support for 
> that particular
> platform?

Not yet, but I did want to look at it.  I need to create a test case without
involving mod_jk2.

> I would rather see that fixed then trying to reinvent the wheel.

Agreed.

But the last emails I saw suggested that the next mod_jk2 2.0.x release
would use either APR 0.95 that came with apache 2.0.x or apr-0.94 which is
the most recent separate release, which is broken.  Hence a chicken and egg
style problem!

Greg

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message