tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Tulley" <JTUL...@novell.com>
Subject RE: allowTrace attribute causing problems in the adminapplication
Date Fri, 27 Feb 2004 22:28:47 GMT
Yeah, I saw this on a newly-downloaded Tomcat 4.1.30 on SUSE linux 8.2,
java 1.3.1 (Sun?)  I first saw it on NetWare, JVM 1.4.2.  I thought it
was something I had done wrong on NetWare, so I quickly tried it on
Linux.

Let me try a restart as you suggest, and try it on Windows with a clean
download.

>>> Larry.Isaacs@sas.com 2/27/04 2:42:54 PM >>>
Hi Jeff,

I tested this before the 4.1.30 release, and just retested it,
and it continues to work for me without your patch.  Since the
protocolHandler doesn't support the "allowTrace" property, the
setProperty() is unnecessary in Tomcat 5.0.x and shouldn't make
a difference in Tomcat 4.1.30.  It is safer to keep the
setProperty() in Tomcat 5 in case somebody cut & pastes the
setAllowTrace() method for some new property that does need it.

Maybe a restart magically made the problem disappear.  Does
your 4.1.30 consistently show this problem without your patch?

Cheers,
Larry

> -----Original Message-----
> From: Jeff Tulley [mailto:JTULLEY@novell.com] 
> Sent: Friday, February 27, 2004 3:48 PM
> To: tomcat-dev@jakarta.apache.org 
> Subject: Re: allowTrace attribute causing problems in the 
> adminapplication
> 
> 
> Actually, if I am not mistaken, the attached txt file patches the
> problem.  An IntrospectionHelper.setProperty was needed for 
> allowTrace. 
> On 5.0.x this was done "automatically" by setting a property in the
> setAllowTrace setter.  Then the properties were set into
> IntrospectionHelper en masse later.
> 
> This patch works for me, at least.
> 
> Attached: patch.txt
> 
> >>> JTULLEY@novell.com 2/27/04 1:13:02 PM >>>
> When I browse to a Coyote Connector in Tomcat's admin in 4.1.30, I
get
> an HTTP 500 error - "Error retrieving attribute allowTrace".  I know
> the
> allowTrace functionality was added about a month ago, and was not a
> required attribute on the connector.
> 
> This functionality works in Tomcat 5.0.19, but not 4.1.30
> 
> Jeff Tulley  (jtulley@novell.com)
> (801)861-5322
> Novell, Inc., The Leading Provider of Net Business Solutions
> http://www.novell.com 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org 
> For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org 
> 
> 
> Jeff Tulley  (jtulley@novell.com)
> (801)861-5322
> Novell, Inc., The Leading Provider of Net Business Solutions
> http://www.novell.com 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org 
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org 


Jeff Tulley  (jtulley@novell.com)
(801)861-5322
Novell, Inc., The Leading Provider of Net Business Solutions
http://www.novell.com

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message