tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Al Banard" <alban...@hotmail.com>
Subject Re: DO NOT REPLY [Bug 27006] - libtool: install: error: cannot install `../../../build/jk2/apache2/jkjni.la' to a directory not ending in /usr/lib/apache2
Date Mon, 01 Mar 2004 07:32:44 GMT
I tried the latest CVS (using --with-apxs2) on the 25th Feb and got exactly 
the same error, unless things have changed with regard to this between now 
and then.


>From: Kurt Miller <truk@apache.org>
>Reply-To: "Tomcat Developers List" <tomcat-dev@jakarta.apache.org>
>To: Tomcat Developers List <tomcat-dev@jakarta.apache.org>
>Subject: Re: DO NOT REPLY [Bug 27006] - libtool: install: error: cannot 
>install `../../../build/jk2/apache2/jkjni.la' to a directory not ending in 
>/usr/lib/apache2
>Date: Thu, 26 Feb 2004 12:27:41 -0500
>
>Are you using the current source from CVS or
>http://cvs.apache.org/snapshots/jakarta-tomcat-connectors/ yet?
>libtool is set correctly for you in the current version. Simply
>configure with --with-apxs2 with current source and it should be
>correctly set for you.
>
>From: "Al Banard" <albanard@hotmail.com>
> > Thanks,
> >
> > Unfortunately my OS is Gentoo and after installing there ebuild
>(basically
> > equivalent to an RPM) directories are all over the place.  The base
>location
> > of apache is actually /etc/apache2 but when I try using this as a
>configure
> > option I get this message:
> >
> > building connector for "apache-2.0"
> > configure: error: can't locate /etc/apache2/
> >
> > and configure dies.
> >
> > Here is a list of the more relevant files that were installed with
>the
> > package.  Do you have any idea as to what I should put as my
>argumernt to
> > the configure option? libtool is in /usr/lib/apache2/build/libtool
>but I've
> > tried passing different combinations of this path without any luck.
> >
> > bash-2.05b# qpkg -l apache
> > net-www/apache-2.0.48-r1 *
> > CONTENTS:
(Please view previous email on this topic for file list, I didn't want to 
keep posting this to keep the post size down)

> >
> >
> > >From: jean-frederic clere <jfrederic.clere@fujitsu-siemens.com>
> > >Reply-To: jfrederic.clere@fujitsu-siemens.com
> > >To: Tomcat Developers List <tomcat-dev@jakarta.apache.org>
> > >Subject: Re: DO NOT REPLY [Bug 27006] - libtool: install: error:
>cannot
> > >install `../../../build/jk2/apache2/jkjni.la' to a directory not
>ending in
> > >/usr/lib/apache2
> > >Date: Tue, 24 Feb 2004 16:16:31 +0100
> > >
> > >Al Banard wrote:
> > > > Hi Henri,
> > > >
> > > > Thanks for giving me help.
> > > >
> > > > OK,  I have to admit I don't know a lot about libtool. I'm using
>apache
> > > > 2.0.48 and have also installed apr-0.9.2. How do I specify to
>use the
> > > > libtool from Apache 2.0 / APR?
> > >
> > >That is what is done when you
>use --with-apache2=$HOME/httpd-2.0.48.
> > >It works for me with the actual CVS and libtool-1.5.2 and
>automake-1.6.1 (I
> > >build and install automake after libtool).
> > >
> > > >
> > > >
> > > >> From: Henri Gomez <hgomez@apache.org>
> > > >> To: Tomcat Developers List <tomcat-dev@jakarta.apache.org>,
> > > >> albanard@hotmail.com
> > > >> Subject: Re: DO NOT REPLY [Bug 27006]  -     libtool: install:
>error:
> > > >> cannot install `../../../build/jk2/apache2/jkjni.la' to a
>directory
> > > >> not ending in /usr/lib/apache2
> > > >> Date: Tue, 24 Feb 2004 14:57:49 +0100
> > > >>
> > > >> Continuing this thread on tomcat-dev.
> > > >>
> > > >> Well you should use the libtool from Apache 2.0 / APR.
> > > >>
> > > >> Which version of Apache 2.0 are you using ?
> > > >>
> > > >>
> > > >> bugzilla@apache.org wrote:
> > > >>
> > > >>> DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG RELATED
>COMMENTS
> > > >>> THROUGH THE WEB INTERFACE AVAILABLE AT
> > > >>> <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=27006>.
> > > >>> ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND
>INSERTED IN
> > > >>> THE BUG DATABASE.
> > > >>>
> > > >>> http://nagoya.apache.org/bugzilla/show_bug.cgi?id=27006
> > > >>>
> > > >>> libtool: install: error: cannot install
> > > >>> `../../../build/jk2/apache2/jkjni.la' to a directory not
>ending in
> > > >>> /usr/lib/apache2
> > > >>>
> > > >>>
> > > >>>
> > > >>>
> > > >>>
> > > >>> ------- Additional Comments From albanard@hotmail.com
>2004-02-24
> > > >>> 13:53 -------
> > > >>> I just tried libtool 1.5.2-r3 and I still get the same error.
>Can you
> > > >>> think of anything else (program versions / configure options /
>steps)
> > > >>> I might be doing differently to you? Here is a recap of my
>steps:
> > > >>>
> > > >>> cd jakarta-tomcat-connectors-jk2-2.0.2-src/jk/native2/
> > > >>> chmod 0777 buildconf.sh
> > > >>> ./buildconf.sh
> > > >>> ./configure --with-java-home=/opt/sun-jdk-1.4.2.03
> > > >>> --with-apxs2=/usr/sbin/apxs2 --with-tomcat41=/usr/local/tomcat
> > > >>> make clean build
> > > >>> libtool --finish /usr/lib/apache2
> > > >>>
> > >
> >>> ------------------------------------------------------------------

_________________________________________________________________
SEEK: Now with over 50,000 dream jobs! Click here  
http://ninemsn.seek.com.au/


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message