tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Gomez <hgo...@apache.org>
Subject Re: jk2 buglets II
Date Mon, 23 Feb 2004 16:45:07 GMT
Greg.Cope@pfizer.com wrote:

> 
> We seem to have another buglet with mod_jk2 2.0.2.  We seem to be unable to
> recreate the bug using ab, but when one of our busiest servers has been
> running for a few hours we get apache children "stuck" (at times upto 100
> children are blocked, which is how we found the issue as the server appeared
> slow).  Looking at server-status we the stalled children appear as:
> 
> 1-0	18136	1/426/426	W 	0.99	1660	0	0.3	1.40
> 1.40 	xxxxxx	xxxxxx	GET /homepage/components/GetTime.jsp HTTP/1.1
> 
> The time since last request (SS in this case 1660) goes up as you would
> expect, yet this is the 2nd slot child. Graceful restarts do not help.  The
> child remains in an apparent "W" (write state).
> 
> This only happens to JK2 served content.  Truss reveals:
> 
> # truss -p 18136
> read(39, 0x00505820, 4)         (sleeping...)
> signotifywait()                 (sleeping...)
> lwp_sema_wait(0xFE30DE60)       (sleeping...)
> 
> 
> (etc ......)
> 
> Any ideas on debugging this?  
> 
> This bug is present in CVS and from 2.0.2.
> 
> Thanks again. (I will shut up soon!)

Which Tomcat on the remote side ?

3.3, 4.0, 4.1, 5.0 ?


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message