tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remy Maucherat <r...@apache.org>
Subject Re: JMX remote and JDK 1.5
Date Fri, 06 Feb 2004 08:34:35 GMT
cmanolache@yahoo.com wrote:
> Remy Maucherat wrote:
> 
> What does it mean ? 
> I saw the 1.5 jmx stuff, but as usual this only works with 1.5 while most
> people will keep using 1.3 or 1.4 for few years. I hope we're not falling
> into the forced upgrade trap :-)

I agree in general. However, I've played with the beta, and it basically 
feels like 1.4.3, with the added language features. I didn't test the 
stability in production, of course, but it looks good so far. I do not 
think we'll end up in a situation like with Java 1.4 when:
- coders didn't want to use the new APIs since they weren't stable and 
tested (NIO)
- people didn't want to upgrade as the JVM itself wasn't stable

> I agree that tomcat should't reinvent the wheel - but provide some mechanism
> for 1.4, maybe similar ( or identical ) with what 1.5 provides. This would
> also allow people with 1.3 or 1.4 to enjoy JMX now. 

I'm talking about JMX remote here. AFAIK, no clients support it right 
now. JDK 1.5 will make it a standard in a hurry, given that you don't 
have to configure or add anything in the application itself. Given that 
there's already support for the other JMX remoting connectors in Tomcat, 
I don't see the need to add something which will only become used once 
JDK 1.5 is out. Now, if someone feels like adding it, I won't complain, 
but I won't do it myself ;)

Rémy

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message