tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 4663] - Broken Pipe under some load
Date Thu, 08 Jan 2004 03:54:10 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=4663>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=4663

Broken Pipe under some load





------- Additional Comments From l_xuebin@hotmail.com  2004-01-08 03:54 -------
We are also experiencing the same error with jboss-3.0.0_tomcat-4.0.3 and 
apache 1.3.27 with jk and the jdk is j2sdk-1_4_1_01-fcs for linux-i586 rpm.
The exception that the jboss caught:
2003-12-30 08:37:51,053 ERROR [org.jboss.web.localhost.Engine] Ajp13Processor
[8009][2] process: invoke
java.net.SocketException: Broken pipe
	at java.net.SocketOutputStream.socketWrite0(Native Method)
	at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92)
	at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
	at org.apache.ajp.Ajp13.send(Ajp13.java:525)
	at org.apache.ajp.RequestHandler.finish(RequestHandler.java:496)
	at org.apache.ajp.Ajp13.finish(Ajp13.java:395)
	at org.apache.ajp.tomcat4.Ajp13Response.finishResponse
(Ajp13Response.java:192)
	at org.apache.ajp.tomcat4.Ajp13Processor.process
(Ajp13Processor.java:435)
	at org.apache.ajp.tomcat4.Ajp13Processor.run(Ajp13Processor.java:495)
	at java.lang.Thread.run(Thread.java:536)

This accoured more often of the low load the system and could cause to 404 
reported by apache.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message