tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject RE: cvs commit: jakarta-tomcat-catalina/catalina/src/share/org/apache/catalina/core StandardHostDeployer.java
Date Wed, 07 Jan 2004 20:35:14 GMT
It isn't beyond the realm of possibility that I am doing
something stupid. This is what I did. Whilst looking into
bug11682 I created a very simple web app (just index.jsp)
made a war and then tried to deploy it via ant. I modified
the build.xml from the manager how-to and added the task
below.
When using the deploy target, the results were as
described previously.
The root cause of the problem is that ExpandWar.expand
doesn't do anything if the context path is an empty string.
Hope this clarifies things.

Mark

<target name="deploy" description="Deploy web application">
  <deploy url="${url}" username="${username}" password="${password}"
          path="" 
war="file:///C:\\javadev\\bugsopen\\bug11682\\build\\bug11682.war" />
</target>

On Wednesday, January 07, 2004 5:35 AM, Remy Maucherat [SMTP:remm@apache.org] 
wrote:
> Mark Thomas wrote:
>
> > When I tested the deploy task, the behaviour I saw was that
> > the original
> > <code>docBase = ExpandWar.expand(host, war, contextPath)<code>;
> > failed to create any files at all in the webapp directory. The
> > root context _was_ displayed in the manager app but when I
> > tried to access it all I saw was a directory listing for the
> > webapp directory.
>
> Hmmm, maybe, I still don't quite see the problem. Can I get an example
> of a deploy command which would fail ?
>
> Remy
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
>



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message