tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <mgai...@hotmail.com>
Subject Re: jk2 .. uncomfortably silent ?
Date Thu, 18 Dec 2003 07:02:46 GMT
Tomcat is a child process (ProcessID=0) to HTTP Server
What is your specific concern?
-Martin
----- Original Message ----- 
From: "NAIK,ROSHAN (HP-Cupertino,ex1)" <roshan.naik@hp.com>
To: "'Tomcat Developers List'" <tomcat-dev@jakarta.apache.org>
Sent: Wednesday, December 17, 2003 7:58 PM
Subject: jk2 .. uncomfortably silent ?


> Wonder why questions on jk2 often never get a response. 
> Are the relevant developers not active on this list ? 
> 
> Even cc-ing the developers who are credited in the relevant source code
> doesnt help !!
> 
> --Roshan
> 
> > -----Original Message-----
> > From: NAIK,ROSHAN (HP-Cupertino,ex1) [mailto:roshan.naik@hp.com]
> > Sent: Monday, December 15, 2003 3:48 PM
> > To: 'Tomcat Developers List'
> > Cc: 'shachor@il.ibm.com'; 'hgomez@slib.fr'
> > Subject: mod_jk2 .. is 0 a valid child_id ?
> > 
> > 
> > mod_jk2 creates this error long entry each time apache starts up...
> > 
> > 
> > [Mon Dec 15 15:20:17 2003] [error] mod_jk child init 1 0
> > 
> > 
> > The relevant code printing the error is in function 
> > jk2_child_init() in
> > mod_jk2.c
> > 
> > static void jk2_child_init(apr_pool_t *pconf, server_rec *s)
> > {
> >  //...
> > 
> >     if( workerEnv->childId <= 0 ) 
> >             env->l->jkLog(env, env->l, JK_LOG_ERROR, "mod_jk 
> > child init %d
> > %d\n",
> >                           workerEnv->was_initialized, 
> > workerEnv->childId );
> >     }
> >  //...
> > }
> > 
> > 
> > Here 0 is assumed to be invalud childID. But other parts of 
> > the code (in the
> > 
> > same function) seem to find the childID>=0 to be fine ....
> > 
> >     if (workerEnv->childId >= 0) {
> >         workerEnv->childGeneration =
> > ap_scoreboard_image->parent[workerEnv->childId].generation;
> >         ++ap_scoreboard_image->parent[workerEnv->childId].generation;
> >     }
> > 
> > ...
> > 
> >     /* Restore the process generation */
> >     if (workerEnv->childId >= 0) {
> >         ap_scoreboard_image->parent[workerEnv->childId].generation =
> > workerEnv->childGeneration;
> >     }
> > 
> > 
> > I am not too clear about the logic ...however it seems like 
> > something is 
> > not right if thar error is being printed each time apache comes up.
> > 
> > -- Roshan 
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
> > 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message