tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 25851] New: - jk2 errors in apache2 error log
Date Thu, 01 Jan 2004 02:12:33 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25851>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25851

jk2 errors in apache2 error log

           Summary: jk2 errors in apache2 error log
           Product: Tomcat 5
           Version: 5.0.16
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Native:JK
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: hander3@terra.com


I'm using Apache 2.0.48, Tomcat 5.0.16 and jk2 2.0.2.
I've compiled jk2 and configured the jk2.properties and workers2.properties 
following the examples. Everything goes ok except that I'm getting some jk2 
errors on the Apache's error_log. Here I post the content of my files:

workers2.properties
-------------------
[logger]
level=ERROR

[config:]
file=${serverRoot}/conf/workers2.properties
debug=0
debugEnv=0

[shm:]
info=Scoreboard. Required for reconfiguration and status with multiprocess 
servers
file=${serverRoot}/logs/jk2.shm
size=1000000
debug=0
disabled=0

[workerEnv:]
info=Global server options
debug=0

[lb:lb]
info=Default load balancer.
debug=0

[channel.socket:localhost:9209]
info=Ajp13 forwarding over socket
port=9209
debug=0

# define the worker.
[ajp13:localhost:9209]
channel=channel.socket:localhost:9209
group=lb

======================================

jk2.properties
--------------
channelSocket.port=9209

======================================

httpd.conf
----------
#All the configuration... (including the LoadModule for jk2)

#Finally, the virtualhosts...

<VirtualHost myserver.domain.com:9100>
    
    <Location "/aplicacion/d">   
        JkUriSet worker ajp13:localhost:9209
    </Location>

</VirtualHost>

======================================

server.xml (I only post the Connector entry)
----------

<Connector port="9209" enableLookups="false" redirectPort="8443" debug="0" 
protocol="AJP/1.3" />

======================================


And now I post the errors I get form the Apache's error_log

[Thu Jan 01 02:39:43 2004] [error] mod_jk child init 1 0
[Thu Jan 01 02:39:43 2004] [error] jk2_init() Can't find child 30494 in 
scoreboard
[Thu Jan 01 02:39:43 2004] [error] mod_jk child init 1 -2

======================================

Although I can access to my servlets, sometimes I get a 500 error. In that 
case, if I call my servlet again, it works fine. Then, the error_log shows more 
errors like those posted above.

I've been searching on Google to see if there was any answer. A lot of people 
are facing the same problem with no results, so I think it might be a bug.

Thanks for your help!

Ricotta.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message