tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 25599] New: - Cannot change the Java VM option in the Configure Tomcat utility
Date Wed, 17 Dec 2003 19:54:08 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25599>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25599

Cannot change the Java VM option in the Configure Tomcat utility

           Summary: Cannot change the Java VM option in the Configure Tomcat
                    utility
           Product: Tomcat 5
           Version: 5.0.16
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Native:Integration
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: curtinjt@hotmail.com


I'm running Tomcat 5 on a Windows XP system with at least 6 different JDKs.  I
have my JAVA_HOME environment variable set to reference the default instance,
the one I use most often.  During the initial installation, the Tomcat installer
asked me to point to the location of the JDK I wanted Tomcat to use, and it
pre-populated the field with the value of the JAVA_HOME variable.  This was
fine, so I left the value alone and continued the installation.  When I checked
the values in the Configure Tomcat tool, I saw that the Java VM option read
simply "java" rather than the value I had seen during installation.  If I try to
change this value, and point to a specific Java executable from a specific JDK
version, Tomcat will not start up.  The process dies almost as soon as I run it,
and it will not come back until I go into the Windows Registry and return the
Java VM value to just "java".   I can find no other way to specify which Java
version Tomcat uses after installation, and I can't verify that it is using the
one I selected during installation.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message