tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 25133] New: - Cannot add responses headers in filter after doFilter
Date Tue, 02 Dec 2003 11:20:30 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25133>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=25133

Cannot add responses headers in filter after doFilter

           Summary: Cannot add responses headers in filter after doFilter
           Product: Tomcat 5
           Version: 5.0.14
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Connector:Coyote
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: kevinj@develop.com


I have a very simple filter that calls response.addHeader both before and after
calling chain.doFilter. Before chaining the header is added, after chaining the
header is not added. Also I cannot set the value of the header after chaining,
or set a cookie.

To see this failure

Try this, browse to http://localhost:8080/index.jsp. For the page itself I see a
200 response and all my headers being set. For the gifs I get a 200 but only the
headers I set *before* calling chain.doFilter are set. If I then refresh I get a
304 Not Modified response (for the gifs) from tomcat and all the headers are set!

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message