tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 24998] New: - Seem to experiencing problems with sessions with multiple connects through a proxy
Date Wed, 26 Nov 2003 01:14:11 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24998>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24998

Seem to experiencing problems with sessions with multiple connects through a proxy

           Summary: Seem to experiencing problems with sessions with
                    multiple connects through a proxy
           Product: Tomcat 3
           Version: 3.3 Final
          Platform: All
        OS/Version: Other
            Status: UNCONFIRMED
          Severity: Normal
          Priority: Other
         Component: Unknown
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: narcher@jspwebtech.com


Hi, we have created intranet solutions for a couple of the projects that we are 
working on, however we are finding that when users connect to our sites through 
a proxy (namly ISA) the sessions are getting confused between the users. Each 
user is seeing the results of the other user. We have generated a random 
parameter for each request to place on the url to try to counter these proxy 
issues, however the issue seems to be in tomcat's (or possibily Apache's as we 
are using a Apache/Tomcat worker setup) session indentification. A problem that 
has emerged resently from this is SOME (not all) of a session's objects (JAVA 
Beans) are been invalidated, while others are not. An example of this is our 
DBManager which uses a predefined and created MaxID class.. This maxID class 
has been invalidated, however the DBManager was not. These are both declared on 
every page by use of a header.jsp which is included.

This may not be a bug, although I have been looking at the problem on and off 
for a month and can't seem to find any information on the issue, or resolve the 
origin of issue.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message