tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timo" <timo-jaka...@telus.net>
Subject <url-pattern> in <filter-mapping> does not work!!!
Date Sun, 16 Nov 2003 07:07:36 GMT
Hi all,
I am using JDeveloper to develop a web application, something I want to do, is to filter all
jsp pages that starts with "res" using the filter "myfilter",
snippet of my web.xml look like:
<filter>
   <filter-name>myfilter</filter-name>
   <filter-class>myfilter</filter-class>
 </filter>
...
<filter-mapping>
   <filter-name>myfilter</filter-name>
   <url-pattern>/res*</url-pattern>
</filter-mapping>

Now, the filter mechanism works perfectly using the development OC4J containter from oracle,
but... when I deploy the war file to tomcat, it seem it didnt recognize the pattern correctly...
and acts as if there is no filter at all, and the filter does not get called!!
I also tried <url-pattern>/res*.jsp</url-pattern> and same results.

here is a snippet from the application log:

2003-11-15 23:04:29 StandardContext[/myapp]: Mapping contextPath='/reserveit' with requestURI='/myapp/resWelcome.jsp'
and relativeURI='/resWelcome.jsp'
2003-11-15 23:04:29 StandardContext[/myapp]:   Trying exact match
2003-11-15 23:04:29 StandardContext[/myapp]:   Trying prefix match
2003-11-15 23:04:29 StandardContext[/myapp]:   Trying extension match
2003-11-15 23:04:29 StandardContext[/myapp]:  Mapped to servlet 'jsp' with servlet path '/resWelcome.jsp'
and path info 'null' and update=true

any help in this case is really really appreciated...
thanks in advance.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message