tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Gomez <hgo...@apache.org>
Subject Re: JK/ajp13 connection reuse problem
Date Tue, 21 Oct 2003 16:02:33 GMT
Andy Armstrong wrote:

> Henri Gomez wrote:
> 
>> The ajp13 disector was introduced in ethereal some months ago
> 
> 
> And I now have a copy of it rather than last year's model :)
> 
> Anyway, the conversation looks like this in summary and a (naive) 
> analysis of the contents of the packets doesn't yield anything obvious.
> 
> -> FORWARD REQUEST
> <- SEND HEADERS
> <- SEND BODY CHUNK
> <- END RESPONSE
> -> FORWARD REQUEST
> -> FORWARD REQUEST
> -> FORWARD REQUEST
> -> FORWARD REQUEST
> -> FORWARD REQUEST
> -> FORWARD REQUEST
> -> FORWARD REQUEST
> -> FORWARD REQUEST
> -> FORWARD REQUEST
> -> FORWARD REQUEST
> -> FORWARD REQUEST
> 
> Should there be anything else before the second FORWARD REQUEST? The 
> Domino end seems to spin in first while loop inside ajp_send_request() 
> because ajp_connection_tcp_send_message() keeps returning JK_TRUE 
> without ae->sd becoming <= 0. Debug indicates that ae->sd retains its 
> initial value on successive trips round the loop.

I've got :

-> FORWARD REQUEST
<- SEND HEADERS
<- SEND BODY CHUNK
<- END RESPONSE (REUSEP:1)

May be something to do with chunk encoding which has been modified
in ajp13/jk (after your works on domino I think)



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message