tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 21763] - Tomcat 4.1.24 hangs under heavy load using http connector.
Date Tue, 21 Oct 2003 23:57:13 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21763>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21763

Tomcat 4.1.24 hangs under heavy load using http connector.





------- Additional Comments From tom@squeat.com  2003-10-21 23:57 -------
I am having the exact same problem using Apache 2 connecting to Tomcat 4.1.24 through 
mod_jk2.

In my case, by watching jkstatus, I noticed that the number of threads in use would increase
once 
every 5 minutes (why, I don't know) until all 75 threads would be used up about 6 hours later.
  
This is on a server with virtually NO LOAD.

Deciding that it was related to connections not being dropped, we changed our connectionTimeout

value for the Connector from 0 to 60000.   So far that seems like it has fixed the problem.
  
Perhaps this will give some further insight into the cause. 

Disclaimer: I haven't applied the attached patches from this bug report.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message