tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <mgai...@hotmail.com>
Subject Re: IP address Assignment problem
Date Wed, 27 Aug 2003 04:37:05 GMT
server.xml:
port="80"

What is your port spec in server.xml?
-Martin
----- Original Message -----
From: "J Raf" <araffoul@hotmail.com>
To: <tomcat-dev@jakarta.apache.org>
Sent: Tuesday, August 26, 2003 6:16 PM
Subject: Re: IP address Assignment problem


> Thank you for your help,
>
> I think this is a bug in TOMCAT running on Windows 2000 and XP. The same
> config works fine on NT.
> I have even setup Tomcat to run on 127.0.0.1:80 (loopback) and IIS to run
on
> the real network address 192.168.1.100:80 on the same machine and it works
> just fine.
>
> Any help is much appreciated.
>
>
> >From: Reshat Sabiq <sabiq@purdue.edu>
> >Reply-To: "Tomcat Developers List" <tomcat-dev@jakarta.apache.org>
> >To: Tomcat Developers List <tomcat-dev@jakarta.apache.org>
> >Subject: Re: IP address Assignment problem
> >Date: Sun, 24 Aug 2003 19:31:01 -0500
> >
> >
> >
> >J Raf wrote:
> >
> >>The machine is configured with different IP addresses. IIS was running
on
> >>a differnt IP address then Tomcat. Both Tomcat on IIS were running on
port
> >>80. Using the IIS adminnstration module you can specify which IP address
> >>IiS should run on.
> >>
> >>Thank you for your help.
> >>
> >>
> >>>From: Reshat Sabiq <sabiq@purdue.edu>
> >>>Reply-To: "Tomcat Developers List" <tomcat-dev@jakarta.apache.org>
> >>>To: Tomcat Developers List <tomcat-dev@jakarta.apache.org>
> >>>Subject: Re: IP address Assignment problem
> >>>Date: Sat, 23 Aug 2003 13:16:31 -0500
> >>>
> >>>
> >>>
> >>>Ayoub Raffoul wrote:
> >>>
> >>>>Hello,
> >>>>
> >>>>I'm running Apache Tomcat ver. 4.1 on a Windows 2000 server. The
machine
> >>>>has multipe IP addresses. I have configured Apache Tomcat in
server.xml
> >>>>to run on a specific IP address port 80 as follows (fake IP address):
> >>>>
> >>>>    <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
> >>>>port="80"               minProcessors="5" maxProcessors="75"
> >>>>               enableLookups="true" redirectPort="8443"
> >>>>               acceptCount="100" debug="0" connectionTimeout="20000"
> >>>>               useURIValidationHack="false"
disableUploadTimeout="true"
> >>>>address="205.200.21.30"/>
> >>>>
> >>>>I also need to run IIS on the same machine though on a different IP
IE:
> >>>>205.200.21.31 and port 80. Each time I try to launch IIS I get an
error
> >>>>message saying port is in use. If I shut down Tomcat then the port get
> >>>>released and I'm able to launch Tomcat. It seems that Tomcat is
> >>>>reserving all ports # 80 for all IP addresses on this machine. This
> >>>>configuration was working correctly in an older version of Tomcat.
> >>>>Even though Tomcat seems to be reserving all port 80 for all IP
> >>>>addresses it is only responding to 205.200.21.30.
> >>>>
> >>>>Vice Versa is also a problem. If I shut down Tomcat and start IIS on
> >>>>205.200.21.31:80, Tomcat will no longer launch on 205.200.21.30:80. It
> >>>>will report that the port is in use.
> >>>>
> >>>>Has anybody encountered a similar issue? Your help is highly
> >>>>appreciated.
> >>>>
> >>>>Thank you
> >>>>
> >>>>___
> >>>
> >>>
> >>>A port denotes an application, so i'm suprised you were previously able
> >>>to have 2 applications on the same machine on the same port. In other
> >>>words, the OS needs be aware and support different-IP-same-port
> >>>distinction. I don't know if Win or others do that.
> >>>
> >>>--
> >>>Sincerely,
> >>>Reshat.
> >>>
>
>>>-------------------------------------------------------------------------
------------------
> >>>
> >>>If you see my certificate with this message, you should be able to send
> >>>me encrypted e-mail. Please consult your e-mail client for details if
you
> >>>would like to do that.
> >>>
> >>><< smime.p7s >>
> >>
> >>
> >OK, i remember reading somewhere that Win can be configured for 2 IPs. I
> >think it may be a problem with the networking setup on that machine. My
> >guess is that the machine's OS (TCP/IP stack in particular) isn't aware
> >that you intend to use 2 IPs, and probably needs to be set up accordingly
> >using some applet.
> >Sorry, not really much help...
> >
> >--
> >Sincerely,
> >Reshat.
> >
>
>---------------------------------------------------------------------------
----------------
> >If you see my certificate with this message, you should be able to send
me
> >encrypted e-mail. Please consult your e-mail client for details if you
> >would like to do that.
> >
> ><< smime.p7s >>
>
> _________________________________________________________________
> Protect your PC - get McAfee.com VirusScan Online
> http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
>
>

Mime
View raw message