tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitry Beransky <>
Subject package javax.servlet does not exist error
Date Thu, 07 Aug 2003 18:18:19 GMT

My apologies if this has been discussed on the list before.  Searching the 
archive returned a bunch of irrelevant results and I couldn't figure out 
how to narrow the search down.

I'm trying to compile Tomcat 4.1.27 on a Windows box with JDK 1.4.2.  I 
have all the packages installed and in 
jakarta-tomcat-4.1.27-src modified to reflect new package locations (btw, I 
had no problems at all compiling Tomcat 4.0.6).  I've downloaded 
jakarta-tomcat-jasper and put it into the same directory as the tomcat 
package.  I've also changed inside jasper2 directory to 
point back to the tomcat project.

Now, when I'm try to run ant and when the compilation process gets around 
to jasper2, I get a punch of messages all of which are complaining about 
the same thing:

   package javax.servlet does not exist

I do have jakarta-servletapi-4 and ${servlet.home} in 
properly points to it.  So why am I getting this error?  What am I missing?


View raw message