tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 22407] New: - Secured connection problem while running catalina as NT service
Date Thu, 14 Aug 2003 08:29:22 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22407>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22407

Secured connection problem while running catalina as NT service

           Summary: Secured connection problem while running catalina as NT
                    service
           Product: Tomcat 4
           Version: 4.1.27
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: erank@valor.com


My servlet opens an SSL connection to a third party.

When running Catalina, using catalina.bat, all works well, but when running it 
using an NT service I get a connection refused error while trying to connect to 
the server.

To eliminate external factors we hardcoded both the system properties of the 
proxy settings and the certificate keystore within the initialization the 
servlet (using System.getProperties().put(...)).
I have also added to the class.path registry entry the JSSE libraries (although 
I'm using j2sdk1.4.1_04), and I can see from the exception trace those 
libraries were indeed loaded.

I cannot see any connection trials on both server and to the proxy server.

The catalina.bat is used as is, and is not modified in any way.

Could anyone point out the differences between the startup procedures of both 
methods (catalina.bat and NT service) that have any relation to my problem?

Mime
View raw message