tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 22149] New: - Reloading with manager causes application to break
Date Tue, 05 Aug 2003 20:28:21 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22149>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22149

Reloading with manager causes application to break

           Summary: Reloading with manager causes application to break
           Product: Tomcat 4
           Version: 4.1.27
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Webapps:Manager
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: netguru@ipudev.com


Using the HTML Manager, Tomcat 4.1.27 on SuSE Linux (I haven't tested this on
any other OS's). When Tomcat first starts up, all the webapps (including
/examples, which I've been testing with) start up fine. When I click 'reload' to
reload the /examples webapp, the manager claims it is not running (false). When
I hit 'Start' I get:

FAIL - Application at context path /examples could not be started
FAIL - Encountered exception java.lang.IllegalStateException: standardHost.start
/examples: LifecycleException:  Container StandardContext[/examples] has already
been started

Which is quite obviously not true, since when I try to access /examples I get

HTTP Status 503 - This application is not currently available

The only way to bring /examples back is to shutdown.sh then startup.sh.

I'm posting this under the manager, although I'm not sure whether the problem
lies there or not; I tried moving the manager webapp from 4.1.24
(tomcat_home/server/webapps/manager) into 4.1.27 and had the same problem.

Using Sun JDK 1.4.1_03. I've tried this on 3 systems (different versions of
SuSE) and all three show the same problem. This problem doesn't exist in Tomcat
4.1.24.

Mime
View raw message