tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 22108] New: - WebDAV not working with "default" servlet mapping
Date Mon, 04 Aug 2003 14:22:09 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22108>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22108

WebDAV not working with "default"  servlet mapping

           Summary: WebDAV not working with "default"  servlet mapping
           Product: Tomcat 5
           Version: 5.0.6
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Minor
          Priority: Other
         Component: Servlets:WebDAV
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: marc.lehmann@infineon.com


The servlet mapping as specified in the deployment descriptor for the webdav 
application (taken from TC 4.1.27) doesn't work. I had to change

<servlet-mapping>
    <servlet-name>webdav</servlet-name>
    <url-pattern>/</url-pattern>
</servlet-mapping>

to

<servlet-mapping>
    <servlet-name>webdav</servlet-name>
    <url-pattern>/*</url-pattern>
</servlet-mapping>

to make things work. This doesn't seem to be compliant with SVR 11.2 of the 
current servlet specification.

Mime
View raw message