tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: [VOTE] 5.0.9 stability rating
Date Mon, 25 Aug 2003 06:56:35 GMT

----- Original Message ----- 
From: "Remy Maucherat" <remm@apache.org>
To: "Tomcat Developers List" <tomcat-dev@jakarta.apache.org>
Sent: Sunday, August 24, 2003 11:25 AM
Subject: Re: [VOTE] 5.0.9 stability rating


> Tim Funk wrote:
> > Installed 5.0.9 from exe (win2k)
> > 1) startup.bat worked fine, but the icon which calls tomcatw.exe"
> > //GT//Tomcat5 fails will some "Current Thread not owner error"
> > 2) Race conditions and connection handling in JDBCRealm - plus a whole
> > host of other JDBCRealm bugs in Bugzilla applicable to 4 and 5. I hope
> > early next week to have a patch which will close many of the JDBCRealm
> > bugs.
> > 3) Need to reinvestigate the JNDIRealm bug reopened.
> >
> > For the first error - I am sure I just need to look through bugzilla, or
> > the archives and just need to add something to the README.  (User error)
>
> This works for me, Bill, and presumably others. There are reports on
> tomcatw in BZ, so it must be at least an uncommon error (given the code
> have stayed stable for a few releases). Even if the bug is mildly
> common, the old shell scripts are still there. I can put a note stating
> that they can be used in case the new .exe wrapper somehow fails.
>
> I'm staying by my "beta" rating. Again, we cannot continue releasing
> alphas just because there could be some non obvious bugs in the build.
> In the current system, the period before the vote is meant to check if
> there are no showstoppers. If the build is mostly clean, it must be a
> beta, otherwise, it merely delays wider testing and finding bugs, which
> is *bad*.
>

Ok.  I'm willing to vote for a (weak) Beta in exchange for a release-note
that Tomcat doesn't implement the current-draft's Authentication
requirements.

> > For the last 2 errors - tomcat can be considered beta or stable with the
> > buggy JNDIRealm and JDBCRealms since the tomcat4.1 version of the same
> > code was part of a stable release.
>
> Remy
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
>
>


Mime
View raw message