tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "srujana" <sruj...@isg.cmcltd.com>
Subject FW: Reg Tomcat 4.1.18 Tags
Date Sat, 05 Jul 2003 11:37:59 GMT


-----Original Message-----
From: srujana [mailto:srujana@isg.cmcltd.com]
Sent: Saturday, July 05, 2003 5:06 PM
To: tomcat-dev-info@jakarta.apache.org
Subject: Reg Tomcat 4.1.18 Tags


Hi

	Am getting problem with Tags/taglibs in Tomcat 4.1.x release.

	I'm using a bean

	<jsp:useBean id="PBN" class="tags.xml.pbean" scope="application" />

	and one tag(user defined)

	<%@ taglib uri="http://prsnltags/tags"  prefix="tags" %>

	where "http://prsnltags/tags" is the uri specified in the tld file for the
classes/tags 	specified in 	the tld file.

	The problem am facing is i'm calling the bean 'PBN' from the tag class
'doStartTag' 	method. But this method is getting fired before using the tag
, but instead its being 	called at the time of declaration means at this
point

	<%@ taglib uri="http://prsnltags/tags"  prefix="tags" %>

	Which is supposed to be called at the point where this tag is used
	say like

	<tags:class parameter="value"/>


We didn't face this problem with Tomcat 4.0.4/3.x version

Read from the net that Tomcat 5.0 addresses/handles Taglibs more smoothly

Pl give your suggestion

Thanks & Regards
Srujana





---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message