tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remy Maucherat <>
Subject Re: [5.0] Optimizing the core a bit more
Date Fri, 18 Jul 2003 16:46:34 GMT
Remy Maucherat wrote:
> In an effort to tweak the core a bit more to simplify things:
> - Remove ContainerBase.invoke: A Container always has a Pipeline 
> associated with it; as such, the Container interface should have a 
> getPipeline method, and this should be called instead. This will reduce 
> a bit the call stack.
> - I noticed the RequestListenerValve was added twice to the pipeline 
> (using the tester). This doesn't seem right, obviously.

Actually, since it is a needed feature for spec compliance, and to 
simplify things a little, it should be in "core", and I'll integrate the 
code in StandardContextValve.

Similarly, the code in the ErrorDispatcherValve should be integrated in 

OTOH, the ErrorReportValve should stay as is as a Valve, as it is not 
required for spec compliance, and it is valid to remove or replace it.

Comments ?


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message