tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 22006] New: - Invalid SMAP line entries when running with mappedfile=true
Date Thu, 31 Jul 2003 00:06:18 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22006>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22006

Invalid SMAP line entries when running with mappedfile=true

           Summary: Invalid SMAP line entries when running with
                    mappedfile=true
           Product: Tomcat 5
           Version: 5.0.5
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Jasper2
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: jschulz@ensemble-systems.com


I'm running Tomcat5.0.5 with JspServlet options "mappedfile=true" 
and "dumpSmap=true".  The SMAP file appears to be incorrect for HTML sections 
of the servlet.

For example, take the following trivial JSP (shown with line numbers):
1 <head>
2   <title>My Title</title>
3 
4 </head>

The corresponding lines in the generated servlet are:
40      out.write("<head>\n");
41      out.write("  ");
42      out.write("<title>My Title");
43      out.write("</title>\n");
44      out.write("\n");
45            out.write("</head>");

Actual LineInfo section of the SMAP file:
*L
1:40,2
2:42
2:43,2
4:45

Expected LineInfo section:
*L
1:40
2:41,3
3:44
4:45

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message