tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 21811] New: - If url-pattern is /*.jsp, filter doesn't run
Date Tue, 22 Jul 2003 19:52:44 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21811>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21811

If url-pattern is /*.jsp, filter doesn't run

           Summary: If url-pattern is /*.jsp, filter doesn't run
           Product: Tomcat 4
           Version: 4.1.24
          Platform: Macintosh
        OS/Version: MacOS X
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Unknown
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: rnewman@thecia.net


If my web application's web.xml file contains this:

    <filter-mapping>
      <filter-name>Test Filter</filter-name>
      <url-pattern>/*.jsp</url-pattern>
    </filter-mapping>

then the filter doesn't run when I invoke a JSP in the application's top-level directory.

If I change the url-pattern to this:

      <url-pattern>*.jsp</url-pattern>

then the filter does run.

I'll upload a .war file and some instructions to demonstrate the problem shortly.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message