tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 3884] - SingleThreadModel servlets not pooled results in low performance
Date Fri, 18 Jul 2003 22:19:54 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3884>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3884

SingleThreadModel servlets not pooled results in low performance

remm@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |RESOLVED
         Resolution|                            |FIXED



------- Additional Comments From remm@apache.org  2003-07-18 22:19 -------
What you're using is a STM JSP, which is not the same as a servlet since its
invoked through a non STM wrapper servlet: the JasperServlet. Pooling cannot be
implemented in that case (unless adding a pool in the JasperServlet itself, but
it would be yet another horrible hack inside Jasper, so I'm -1 for it).

If you want to get the same behavior as with a regular STM servlet, you have to
precompile your JSP (and map it in web.xml), in which case Catalina will
identify your servlet as STM and pool it.

I'm reverting to the old resolution.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message