tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 21666] - Form-based authentication doesn't work
Date Wed, 16 Jul 2003 23:33:58 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21666>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21666

Form-based authentication doesn't work





------- Additional Comments From hans@gefionsoftware.com  2003-07-16 23:33 -------
Sorry about that. It _did_ fail as described on one machine, but it may have
been related to other issues with the new forward behavior and relative paths.
Anyway, on a new installation it seems to work as advertised. I should have
investigated further before filing a report, but I figured it was a trivial bug
introduced by the switch to forward.

Regarding forward vs. redirect, I think it would be better if the spec was clear
about which method _must_ be used to minimize portability concerns. Forward
makes it easier to deal with POST data, but it has issues with relative links in
the login/error pages. Still, maybe forward is best. It's too late to fix this
in the 1.4 spec, so I guess we'll have to live with this potential
incompatibility for a while.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message