tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Halstead <ch...@precisionsite.com>
Subject TC5 Clustering & JDK 1.4.2
Date Mon, 21 Jul 2003 23:04:01 GMT
Has anyone else seen issues with TC5 clustering and Sun's 1.4.2 JDK on
Linux?

Here's my setup:

- Redhat 9.0 w/latest RHN patches
- Sun JDK 1.4.2 build 1.4.2-b8
- Tomcat 5.0.4 Alpha binary release
- Four TC5 instances on the local machine, all identical save for port
assignments for shutdown port, Coyote/HTTP port and TCP replication
port.

I've tested this on two seperate RH9 machines and get exactly the same
result.  When using JDK 1.4.2, replication (as reported in catalina.out
with cluster debug=10) usually works for the very first session created
but then is sporadic from then on.  Sometimes replication is sporadic
from the start.  To create a session I removed the <%@ page
session="false" %> statement in the index.jsp of the sample ROOT
application and then use 'curl -I http://localhost:NNNN/index.jsp' and
watch catalina.out for the replication messages.

When I switch to JDK 1.4.1 (any sub-version), all works normally.

I can provide more in-depth config information if anyone wants it...just
let me know.

cheers,

-chris


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message