tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Danh Duy Bui <danh...@psv.com.vn>
Subject Problem Realm to work with Oracle
Date Thu, 31 Jul 2003 06:37:36 GMT
Hello Sir,
I am  Setting up and enabling container-managed authentication for Tomcat
4.1.12 . Now, I am getting some problem with Realm tag.
I have been succesful authenticated with userDatabaseRealm using file
tomcat-user.xml like the tag below
<Realm className="org.apache.catalina.realm.UserDatabaseRealm"
                 debug="0" resourceName="UserDatabase"/>

However, when I have changed the Realm tag (in the server.xml file) to
connect to Oracle DB server as below

<Realm className="org.apache.catalina.realm.JDBCRealm" debug="99"
             driverName="oracle.jdbc.driver.OracleDriver"
          connectionURL="jdbc:oracle:thin:@teds-p-orc-d:1521:TEDS9ID"
		  connectionName="teds" connectionPassword="teds"
              userTable="users" userNameCol="USER_NAME"
userCredCol="USER_PASS" 
          userRoleTable="user_roles" roleNameCol="ROLE_NAME"/>

In the Oracle server, I have inserted some appropriate value a below
- insert into users(user_name,user_pass) values('u', 'p')
- insert into users(user_name,role_name) values('u', 'manager')

I have configured on web.xml (Please see the attached file)
I am getting an error(please see the attached file)
 <<catalina_log.2003-07-31.txt>>  <<web.xml>> 

Please help me to clarify this problem and give me some solutions for this.

I am looking forward to hearing from all of you

Thanks,
Danh



Mime
View raw message