tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Gomez <hgo...@apache.org>
Subject Re: [ANN] Apache Tomcat mod_jk 1.2.4 Web Server Connector released
Date Tue, 17 Jun 2003 08:13:05 GMT
jean-frederic clere wrote:
> Henri Gomez wrote:
> 
>>>>
>>>> BTW, the JF-Clere fix in configure.in to use the libtool in Apache 
>>>> 2.0 case, don't works with Redhat 8.0/9.0 where there is an Apache 
>>>> 2.0.40 with post 2.0.40 security fixes.
>>>
>>>
>>>
>>>
>>> And what is the error? It works with a vanilla Apache-2.0.40.
>>
>>
>>
>> I don't know what they do with their 2.0.40 version but here is what 
>> I've got :
> 
> 
> I don't think that changes in apxs are the problem.
> But I think that there must be something weird in build/config_vars.mk
> What does apxs -q LIBTOOL returns?

It didn't works :

Use of uninitialized value in concatenation (.) or string at 
/usr/sbin/apxs line 261.

> And:
> $APXS -q PREFIX
> $APXS -q INCLUDEDIR
> $APXS -q CFLAGS
> $APXS -q EXTRA_CFLAGS
> $APXS -q EXTRA_CPPFLAGS

All of them works.

> Could you send me the build/config_vars.mk?

attached.

> 
> The basic problem is that we use 2 LIBTOOL: In some places (like 
> commons) LIBTOOL is the result of `apxs -q LIBTOOL` and in other places 
> (like apache-2.0) LIBTOOL is the make variable included from 
> build/config_vars.mk. I do not understand why they are different because 
> apxs reads from build/config_vars.mk!!!

Yes we should unify.

PS: Some beers on July/August ;-)



Mime
View raw message