tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17867] - new virtual host doesn't work after restart
Date Mon, 02 Jun 2003 17:35:01 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17867>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17867

new virtual host doesn't work after restart

wchandler@redesetgrow.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|WORKSFORME                  |



------- Additional Comments From wchandler@redesetgrow.com  2003-06-02 17:35 -------
I'm having this same problem.  I go into the admin application and add a virtual
host.  Everything will work for a while.  Then it appears that after the log
file is updated I have problems.  I have noticed that with autodeploy if i have
a WEB-INF directory under a directory then I will have a new context deployed in
my file.  Thus the server.xml file has been overwritten.  I also notice that
when I change the file with VI I have problems after a save and restart.  I have
yet to figure out how to add a vhost by the text file.  When I do it just
doesn't work.  I don't know if it is the xml parser or what, but all I get is no
context configured.  But the same values work when created by the admin tool and
commit changes, but to get it working again I always have to delete the
confiuration (the entire host) then add it all back, aliases, contexts, anything
and everything.  Not good.  I kept it simple this time.  No alias and only one
context other than the default.  And, it still did the same thing.

OS: Red Hat Linux 9
Kernel: 2.4.20-13.9
JDK: 1.4.1_02 SUN  same thing with 1.3.1 SUN
Tomcat: 4.1.24

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message